Requirements for Robo Shield

In order for Robo Shield to work, the application needs to be installed on an iPhone that has a North American telephone number and is running OS 11.4 or higher.

 

Was this article helpful?
6 out of 7 found this helpful